【通达信】一个很好的主图指标

向下

【通达信】一个很好的主图指标

帖子 由 小手冰凉 于 2013-01-12, 17:10

代码:
VAR3:=LLV(HIGH,240);
 VAR4:=100*(CLOSE-VAR3)/VAR3;
 VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
 VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
 VAR7:=0;
 VAR8:=***A(MAX(CLOSE-REF(CLOSE,1),0),34,1)/***A(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
 VAR9:=***A(MAX(CLOSE-REF(CLOSE,1),0),13,1)/***A(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
 VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
 VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
 VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
 VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
 VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
 VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
 VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
 VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
 VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
 VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
 买1:=VAR10;
 买2:=(VAR11+VAR13+VAR15+VAR17);
 卖1:=(VAR12+VAR14+VAR16+VAR18);
 B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
 S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
 VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
 VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
 VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
 F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLORFF00FF;
 DRAWTEXT(CROSS(S,卖1),S,'←逃'),COLORWHITE,LINETHICK1;
 DRAWTEXT(CROSS(B,买1),B,'←准备'),COLORRED,LINETHICK1;
 PH:=TROUGHBARS(2,5,1);
 LL:=HHV(H,PH);
 TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
 TS:=SUMBARS(TJ1,2);
 TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
 DRAWICON(TJ,HIGH*1.01+0.02,2);
 警告灯:IF(TJ,HIGH*1.008,DRAWNULL),CROSSDOT,LINETHICK2,COLORCYAN;
 PL:=BARSLAST(TJ);
 支撑:IF(BARSLAST(TJ1),
 REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
 压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
 TJ_2:=LOW>REF(REF(LOW,TS),PL);
 DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
 DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOREA91B5;
 突破:=REF(EMA(C,14),1);
 A1X:=(EMA(C,10)-突破)/突破*100;
 AAC:=CROSS(A1X,0);
 JZ:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1));
 DRAWICON(AAC,JZ*0.98,9);
 LC:=REF((O+H+L+2*C)/5,1);
 RSI:=***A(MAX(C-LC,0),7,1)/***A(ABS(C-LC),7,1)*10;
 TYP:=(HIGH+LOW+CLOSE)/3;
 CCI:=(TYP-MA(TYP,23))/(0.015****EDEV(TYP,23));
 买:=CROSS(RSI,7.1) AND MA(V,5)>MA(V,10),COLORRED;
 DRAWTEXT(CROSS(RSI,7.1) AND MA(V,5)>MA(V,10),L,'◆▲短线黑马▲◆'),COLORLIGREEN;
 DRAWICON(买,(LOW * 0.98),17);
 卖:=CROSS(7.1,RSI) AND MA(V,10)>MA(V,5),COLORGREEN;
 DRAWTEXT(CROSS(7.1,RSI) AND MA(V,10)>MA(V,5),H*1.04,'■▼逃跑▼■'),COLORYELLOW;
 DRAWICON(卖,(H*1.03),28);



avatar
小手冰凉
幼儿园
幼儿园

帖子数 : 12
威望 : -2
注册日期 : 13-01-12

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 y928 于 2013-01-19, 06:25

新开站先顶一个,谢谢分享!
avatar
y928
班主任
班主任

帖子数 : 756
威望 : 5
注册日期 : 13-01-19

返回页首 向下

请指教

帖子 由 杨树 于 2013-01-19, 07:02

错误句 :
VAR8:=***A(MAX(CLOSE-REF(CLOSE,1),0),34,1)/***A(ABS(CLOSE-REF(CLOSE,1)),7,1)*100
详细信息 : 您在括号前写的不是函数、公式等,
且缺少必要的运算符!
错误起始位置 : 159 ; 长度: 3
avatar
杨树
幼儿园
幼儿园

帖子数 : 12
威望 : 0
注册日期 : 13-01-19

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 鼎泰哥 于 2013-01-19, 09:02

新开站先顶一个,谢谢分享!
avatar
鼎泰哥
幼儿园
幼儿园

帖子数 : 20
威望 : 0
注册日期 : 13-01-19

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 清风竹林 于 2013-01-20, 17:29

哈哈....新人老兵
avatar
清风竹林
幼儿园
幼儿园

帖子数 : 5
威望 : 0
注册日期 : 13-01-20

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 月上柳梢头 于 2013-01-21, 04:26

支持楼主,大家都来支持啊~~楼主再接再厉啊!!
avatar
月上柳梢头
班主任
班主任

帖子数 : 14
威望 : 0
注册日期 : 13-01-21

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 平常心 于 2013-01-25, 03:58

谢谢楼主的分享
avatar
平常心
幼儿园
幼儿园

帖子数 : 15
威望 : 0
注册日期 : 13-01-20

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 hainer 于 2013-01-27, 07:40

楼主再接再厉啊
avatar
hainer
幼儿园
幼儿园

帖子数 : 48
威望 : 0
注册日期 : 13-01-27

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 叟言无忌 于 2013-02-21, 18:40

楼主再接再厉啊
avatar
叟言无忌
幼儿园
幼儿园

帖子数 : 29
威望 : 0
注册日期 : 13-02-20

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 小文 于 2013-03-03, 17:35

楼主再接再厉啊Very Happy
avatar
小文
幼儿园
幼儿园

帖子数 : 6
威望 : 0
注册日期 : 13-01-22

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 野火球 于 2013-12-07, 06:54

谢谢楼主的分享
avatar
野火球
幼儿园
幼儿园

帖子数 : 7
威望 : 0
注册日期 : 13-12-07

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 阿朱 于 2014-07-20, 14:14

支持楼主发指标,但这个指标安装有问题???
avatar
阿朱
幼儿园
幼儿园

帖子数 : 7
威望 : 0
注册日期 : 14-07-20

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 阿朱 于 2014-07-20, 14:16

这个论坛人太少了!
avatar
阿朱
幼儿园
幼儿园

帖子数 : 7
威望 : 0
注册日期 : 14-07-20

返回页首 向下

回复: 【通达信】一个很好的主图指标

帖子 由 jiloobth 于 2014-07-25, 06:18

谢谢楼主的分享
avatar
jiloobth
幼儿园
幼儿园

帖子数 : 8
威望 : 0
注册日期 : 14-07-21

返回页首 向下

返回页首


 
您在这个论坛的权限:
不能在这个论坛回复主题